Reply To: Kega Fusion crashes when loading roms

Seize the game – carpe ludum! Forums Eidolon’s Tavern Kega Fusion crashes when loading roms Reply To: Kega Fusion crashes when loading roms

#517
Jimb1961
Participant

Good day to you,

My system is an: Asus Desktop CM1754, AMD A8-5500 APU (currently using a discrete video card) AMD Radeon HD 6670 with 1gb GDDR5.
I have installed every Directx 9c redistributable and Microsoft Visual C++ from 2005,2008,2010,2012,2013. My graphics card has the most current drivers, just checked website.

Am getting the same error-a crash while selecting a new rom in Kega, fullscreen or windowed. Have also tried both Microsoft ACT and DDraw.dll file which I am currently capable of implementing. To add I have tried: Putting Fusion.exe in UAC exceptions, using compatibility mode troubleshooter, changing the Fusion.ini, turning on and off numerous combinations of Kega video, audio, check options. Using power off option before loading a new rom.
UAC exception does not seem to make any difference, Compatiblity mode works with run as administrator and 256 colors, as mentioned. I can load all Genesis,Sega Master system, and Game Gear games from within Kega one after another with sound enabled. What happens is a lot of the video options disappear, for example resolution changing, and Fixed aspect Fit, Zoom, Brighten, etc. What remains though are the video filters which work for my system. I did get a crash using normal video option in 256 color mode plus, a surface display error stating essentially I needed to run in 16bit color or 32 true color.

Also, I noticed a strange problem in all modes with opening certain zipped Game Gear games,namely a crash; which did not happen them unzipped. Genesis and Master System games were not affect by this.

And finally, I looked at EVENT VIEWER to see what it said, I have only guesses at what I saw and read there. The following is from EVENT VIEWER.

Log Name: Application
Source: Application Error
Date: 2/27/2015 5:43:49 PM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer:
Description:
Faulting application name: Fusion.exe, version: 0.0.0.0, time stamp: 0x4b927620
Faulting module name: SHELL32.dll, version: 6.3.9600.17485, time stamp: 0x54600f68
Exception code: 0xc0000005
Fault offset: 0x00653725
Faulting process id: 0x13b0
Faulting application start time: 0x01d052e718a24de4
Faulting application path: C:\Program Files (x86)\Kega Fusion\Fusion.exe
Faulting module path: C:\WINDOWS\SYSTEM32\SHELL32.dll
Report Id: 7a22a510-beda-11e4-8015-08606e455069
Faulting package full name:
Faulting package-relative application ID:

Hope this helps out.