Problem with Sega CD Games

Seize the game – carpe ludum! Forums Eidolon’s Tavern Problem with Sega CD Games

Viewing 5 reply threads
  • Author
    Posts
    • #481
      manumanu
      Participant

      Hello,

      I can’t seem to play Sega CD game (Shining Force CD, to be more specific) with proper music on Kega Android. In bin/cue format, the music kinda gets mixed with static, and with iso/wav, music is played at double speed! Any ways to fix this?
      Help appreciated!!

    • #483
      Eidolon
      Moderator

      Hi manumanu, you may try with a different setting of the “perfect synch” option. But most likely, it is a bad version of the bin/cue and iso/wav files for the game (bad rip maybe?).

      P.S. I didn’t know there was an Android version of Kega Fusion… 😉

      • #500
        Blastprocessor
        Participant

        I have a similar problem trying to run Ryse of the Dragon on Fusion 3.64. I tried
        turning the perfect sync on and off but it just restart back to the Sega CD logo after the Sonic logo. maybe it’s just a bad rip but I’m still not sure. Any suggestions?

        • #501
          syntax
          Participant

          Have you tried using another bios? I pretty sure Kega has a
          preference for the model 1 bios (v1.10).

        • #510
          PrOcYoN
          Participant

          “Rise of the Dragon” doesn’t work in Kega Fusion 3.64, because of a little problem into this version of the Emulator. T_T However, you should use Fusion 3.63, where this SegaCD ISO works just fine. ;D

    • #484
      manumanu
      Participant

      Actually it’s called MD Emu, a different emulator.
      Still haven’t worked it out but thanks!

    • #492
      King
      Participant

      MD.Emu isn’t based on Kega though, it’s based on Genesis Plus GX (an outdated version, actually).

    • #511
      PrOcYoN
      Participant

      I’ll try it out into Fusion, and then I’ll tell you. C=

    • #521
      PrOcYoN
      Participant

      Works perfectly on KEGA Fusion 3.64! ^o^ Just don’t forget to enable Perfect Sync, and use the proper BIOS version… ;D

Viewing 5 reply threads
  • You must be logged in to reply to this topic.